7.8.2 Error building an Android app

This forum designated to discuss the TsiLang Components Suite.
Post Reply
Malcolm
Posts: 107
Joined: Tue Jan 21, 2003 5:18 pm
Location: Scotland

7.8.2 Error building an Android app

Post by Malcolm »

I have installed 7.8.2 OK for Delphi and Android 10.4

Seems OK for Win32, but when I build an Android app I am getting the following error messages from siComp:

dccaarm command line for "APad.dpr"
...
[DCC Error] siComp.pas(10986): E2157 Element 0 inaccessible - use 'Length' or 'SetLength'
[DCC Error] siComp.pas(10987): E2157 Element 0 inaccessible - use 'Length' or 'SetLength'
[DCC Error] siComp.pas(10998): E2157 Element 0 inaccessible - use 'Length' or 'SetLength'
[DCC Error] siComp.pas(12216): E2157 Element 0 inaccessible - use 'Length' or 'SetLength'
[DCC Error] siComp.pas(12226): E2157 Element 0 inaccessible - use 'Length' or 'SetLength'
[DCC Error] siComp.pas(12226): E2157 Element 0 inaccessible - use 'Length' or 'SetLength'
[DCC Error] siComp.pas(12237): E2157 Element 0 inaccessible - use 'Length' or 'SetLength'
[DCC Error] siComp.pas(12237): E2157 Element 0 inaccessible - use 'Length' or 'SetLength'
[DCC Fatal Error] Main.pas(74): F2063 Could not compile used unit 'SiComp.pas'

(I get the same errors for 32-bit and 64-bit)

Malcolm

Malcolm
Posts: 107
Joined: Tue Jan 21, 2003 5:18 pm
Location: Scotland

Re: 7.8.2 Error building an Android app

Post by Malcolm »

It seems that your attempt to define SI_STR_START for DELPHIXE104 and SIMOBILEAPP has not worked .. or not for me.
Do I need to add a define? That would surprise me.

Malcolm
Posts: 107
Joined: Tue Jan 21, 2003 5:18 pm
Location: Scotland

Re: 7.8.2 Error building an Android app

Post by Malcolm »

OK. Adding the define DELPHIXE104 in my Project Options has solved it for me. :D

Is it your official requirement that a Delphi Android app needs both FMX and DELPHIXE104 to be added to the 'Conditional defines'?

Malcolm

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Re: 7.8.2 Error building an Android app

Post by isiticov »

Sorry for this, install script has used the wrong version of .INC file to include into the setup. We will fix this shortly, meantime you can just modify SI.INC file by adding:

Code: Select all

      {$IF (CompilerVersion >=34)} // Delphi XE10.4
      {$DEFINE DELPHIXE104} // return strings to be 1 based for mobile compilers
      {$IFEND}
after the code:

Code: Select all

	{$IF (CompilerVersion >=33)} // Delphi XE10.3
      {$DEFINE DELPHIXE103} // enabled Linux comps regs
      {$IFEND}
Or just re-download the setup from our web site in several minutes. :)

Malcolm
Posts: 107
Joined: Tue Jan 21, 2003 5:18 pm
Location: Scotland

Re: 7.8.2 Error building an Android app

Post by Malcolm »

Thanks Igor. That edit in SI.inc does the trick .. of course. :D

Post Reply