Page 1 of 1

Error: "Keyset does not exist"

Posted: Tue Oct 26, 2010 11:23 am
by plumothy
I have downloaded and installed the trial Task Scheduler. It looks as if it will be just what I need.

I ran the demo and clicked on the "New Task" button. When the wizard finished, it gave me the error "Keyset does not exist".

The new task was not in the list. But after I clicked on Refresh, it appeared. However, it does not run at the scheduled time.

I am running Win XP SP3 and Delphi 2006.

Am I doing something wrong or are there some settings on my PC that I need to change?

Posted: Thu Oct 28, 2010 4:36 am
by isiticov

This is quite strage. Could you please let us know what kind of task do you create and the settings you use for it?

Posted: Thu Oct 28, 2010 8:30 am
by plumothy
It is just a small console program that I have written to log into a database and issue a backup command. I want to use the VCL Scheduling Agent to write another application that will make it easy for my customers to schedule the console application to backup their database.

Since my original post, I have tried using Windows to create scheduled tasks and that also produces a load of errors.

So, I assume there is something wrong with my Windows installation although I have no idea what it could be and I am certainly not going to re-install Windows to fix it.

So, unless you have any ideas, I will just have to live with it and test my scheduling application on another machine.