TsiLang Expert minor issues in 7.8

This forum designated to discuss the TsiLang Components Suite.
Post Reply
Malcolm
Posts: 107
Joined: Tue Jan 21, 2003 5:18 pm
Location: Scotland

TsiLang Expert minor issues in 7.8

Post by Malcolm »

I have been exploring the Options in more detail and spotted the following glitches, see screenshot:

1. The File name template remembers my .sib extension but the radio button always selects SIL

2. Although I have selected "Remember these settings and don't ask for file name" .. it does prompt me to select the file name when I Save the project.

I am not sure if these are bugs or if I have some other conflicting setting.

Malcolm
Image

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

Hello Malcolm,

Thank you for reporting these.
1- Will check this.
2- These settings apply when you load/save translations for the project(s) using Project Manager popup-menu, not from TsiLang Expert.
Best regards,
Igor Sitikov.

Malcolm
Posts: 107
Joined: Tue Jan 21, 2003 5:18 pm
Location: Scotland

Post by Malcolm »

1. OK, thanks. It will look better when the radio button matches.

2. Actually rather than a prompt, I think that it is really asking for confirmation and I am happy about that.

But it does seem that the TsiLang Expert does not always read and use the .siproj settings when changing projects. For each of my Projects the .siproj file contains the expected settings, but if I try the following, the new settings are not always shown as expected:

1. Launch the IDE (Rio 10.3.3 in my case)
2. Open 'Project1'
3. Tools > TsiLang Expert (or Ctr+L)
4. From Ribbon Bar select Options > Save & Load
5. Expect: the Folder to show 'correct' folder (as in .siproj)
6. Actual: it may be 'correct' but may not (see next)
7. Close 'Project1'
8. Open 'Project2' or whatever
9. Repeat from 3 to 6 above and note the Folder has probably not changed to match the Project2.siproj settings.

The full path and file name does appear to be displayed correctly when the Load or Save dialog is opened so it will probably 'work' OK although the wrong folder may be opened. So it is not really a bug, just a UI glitch.

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

Actually, this is an OS's behavior when there is no specified InitialDir for open/save dialog. It remembers the last folder and then re-uses it.
The InitialDir for open/save dialog components was not set intentionally in order to let OS to control this. But I agree this may be confusing.
We will check/improve this.
Best regards,
Igor Sitikov.

Malcolm
Posts: 107
Joined: Tue Jan 21, 2003 5:18 pm
Location: Scotland

Post by Malcolm »

Version 7.8.0.1 now remembers the translation file extension, Thanks.

For the record, my comments about the default folder were based on misunderstanding the purpose of that setting, sorry. :oops:

It was only when I experimented with the TsiLang Expert's Configuration Wizard today that I found a good description of that setting. It allows the developer to specify a common folder to be used for the translation files of every Project. So it is WAD.

By clearing that setting, Saving/Loading now works the way I expected. :D

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

Thank you.
Best regards,
Igor Sitikov.

Post Reply