SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

GetClass does not work after using TsiLang-Components

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> General
View previous topic :: View next topic  
Author Message
SabrinaK



Joined: 22 Jun 2016
Posts: 1

PostPosted: Wed Jun 22, 2016 1:12 pm    Post subject: GetClass does not work after using TsiLang-Components Reply with quote

Hello everybody,

At first I register the class TUniFrame1 with

RegisterClass(TUniFrame1);

After this I use the following code to get an instance of this class:

procedure TMainForm.UniButton1Click(Sender: TObject);
var
AClass: TPersistentClass;
begin
AClass := GetClass('TUniFrame1');
end;

This works exactly how it should. Afterwards there is an instance of TUniFrame1 in AClass.

But as soon as I use a TsiLang-Component (doesn't matter which one) this does not work anymore. From now on GetClass('TUniFrame1') returns nil.

Can somebody help me? This would be great Smile

Thank you.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2071

PostPosted: Thu Jun 23, 2016 8:54 am    Post subject: Reply with quote

Hello,

What version of TsiLang Components Suite do you use? Does the same happens for you if you use regular TFrame instead of TUniFrame?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group